Skip to content

fix(deps): update dependency sass to v1.72.0 - autoclosed

Renovate requested to merge renovate/sass-1.x into main

This MR contains the following updates:

Package Type Update Change
sass dependencies minor 1.69.0 -> 1.72.0

Release Notes

sass/dart-sass (sass)

v1.72.0

Compare Source

  • Support adjacent /s without whitespace in between when parsing plain CSS expressions.

  • Allow the Node.js pkg: importer to load Sass stylesheets for package.json exports field entries without extensions.

  • When printing suggestions for variables, use underscores in variable names when the original usage used underscores.

JavaScript API
  • Properly resolve pkg: imports with the Node.js package importer when arguments are passed to the JavaScript process.

v1.71.1

Compare Source

Command-Line Interface
  • Ship the musl Linux release with the proper Dart executable.
JavaScript API
  • Export the NodePackageImporter class in ESM mode.

  • Allow NodePackageImporter to locate a default directory even when the entrypoint is an ESM module.

Dart API
  • Make passing a null argument to NodePackageImporter() a static error rather than just a runtime error.
Embedded Sass
  • In the JS Embedded Host, properly install the musl Linux embedded compiler when running on musl Linux.

v1.71.0

Compare Source

For more information about pkg: importers, see the announcement on the Sass blog.

Command-Line Interface
  • Add a --pkg-importer flag to enable built-in pkg: importers. Currently this only supports the Node.js package resolution algorithm, via --pkg-importer=node. For example, @use "pkg:bootstrap" will load node_modules/bootstrap/scss/bootstrap.scss.
JavaScript API
  • Add a NodePackageImporter importer that can be passed to the importers option. This loads files using the pkg: URL scheme according to the Node.js package resolution algorithm. For example, @use "pkg:bootstrap" will load node_modules/bootstrap/scss/bootstrap.scss. The constructor takes a single optional argument, which indicates the base directory to use when locating node_modules directories. It defaults to path.dirname(require.main.filename).
Dart API
  • Add a NodePackageImporter importer that can be passed to the importers option. This loads files using the pkg: URL scheme according to the Node.js package resolution algorithm. For example, @use "pkg:bootstrap" will load node_modules/bootstrap/scss/bootstrap.scss. The constructor takes a single argument, which indicates the base directory to use when locating node_modules directories.

v1.70.0

Compare Source

JavaScript API
  • Add a sass.initCompiler() function that returns a sass.Compiler object which supports compile() and compileString() methods with the same API as the global Sass object. On the Node.js embedded host, each sass.Compiler object uses a single long-lived subprocess, making compiling multiple stylesheets much more efficient.

  • Add a sass.initAsyncCompiler() function that returns a sass.AsyncCompiler object which supports compileAsync() and compileStringAsync() methods with the same API as the global Sass object. On the Node.js embedded host, each sass.AsynCompiler object uses a single long-lived subprocess, making compiling multiple stylesheets much more efficient.

Embedded Sass
  • Support the CompileRequest.silent field. This allows compilations with no logging to avoid unnecessary request/response cycles.

  • The Dart Sass embedded compiler now reports its name as "dart-sass" rather than "Dart Sass", to match the JS API's info field.

v1.69.7

Compare Source

Embedded Sass
  • In the JS Embedded Host, properly install the x64 Dart Sass executable on ARM64 Windows.

v1.69.6

Compare Source

  • Produce better output for numbers with complex units in meta.inspect() and debugging messages.

  • Escape U+007F DELETE when serializing strings.

  • When generating CSS error messages to display in-browser, escape all code points that aren't in the US-ASCII region. Previously only code points U+0100 LATIN CAPITAL LETTER A WITH MACRON were escaped.

  • Provide official releases for musl LibC and for Android.

  • Don't crash when running meta.apply() in asynchronous mode.

JS API
  • Fix a bug where certain exceptions could produce SourceSpans that didn't follow the documented SourceSpan API.

v1.69.5

Compare Source

JS API
  • Compatibility with Node.js 21.0.0.

v1.69.4

Compare Source

  • No user-visible changes.

v1.69.3

Compare Source

Embedded Sass
  • Fix TypeScript type locations in package.json.

v1.69.2

Compare Source

JS API
  • Fix a bug where Sass crashed when running in the browser if there was a global variable named process.

v1.69.1

Compare Source

  • No user-visible changes.

Configuration

📅 Schedule: Branch creation - At any time (no schedule defined), Automerge - At any time (no schedule defined).

🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.

Rebasing: Whenever MR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 Ignore: Close this MR and you won't be reminded about this update again.


  • If you want to rebase/retry this MR, check this box

This MR has been generated by Renovate Bot.

Edited by Renovate

Merge request reports